web-dev-qa-db-ger.com

Bitte geben Sie in Ihrem Podfile eine Plattform für dieses Ziel an.

Ich möchte Firebase Firestore konfigurieren. Ich habe den ganzen Schritt befolgt, aber beim letzten Schritt habe ich den unten erwähnten Fehlerlink erhalten.

Nach dem Ausführen dieses Pods installiere ich Commends unterhalb des Fehlers, den ich bekommen habe

[!] Plattform ios automatisch mit Version 11.4 Auf Ziel testing_gowtham Zuweisen, da keine Plattform angegeben wurde. Bitte geben Sie in Ihrem Podfile eine Plattform für dieses Ziel an. Siehe https://guides.cocoapods.org/syntax/podfile.html#platform.

Mein PodFile:

# Uncomment the next line to define a global platform for your project
# platform :ios, '9.0'

target 'testing_gowtham' do
  # Comment the next line if you're not using Swift and don't want to use dynamic frameworks
  use_frameworks!


  # Pods for testing_gowtham

  target 'testing_gowthamTests' do
    inherit! :search_paths
    # Pods for testing
  end

  target 'testing_gowthamUITests' do
    inherit! :search_paths
    # Pods for testing
  end

    pod 'Firebase/Core'
    pod 'Firebase/Firestore'
end

Ich habe dies gesehen https://guides.cocoapods.org/syntax/podfile.html#platform aber ich habe nicht gefunden, welche Zeile ich ändern muss.

Wie kann man dieses Problem lösen?

14
Gowthaman M

Ersetzen Sie den Text Ihrer gesamten Pod-Datei durch den folgenden Text und überprüfen Sie ihn.

# Uncomment the next line to define a global platform for your project

# platform :ios, '9.0'

target 'testing_gowtham' do

use_frameworks!


pod 'Firebase/Core'
pod 'Firebase/Firestore'
end

(oder) Lösung 2

platform :ios, '9.0' funktioniert ... Ich habe einfach entfernt # this

26
aBilal17
# Uncomment the next line to define a global platform for your project
 platform :ios, '9.0'

target 'testing_gowtham' do
  # Comment the next line if you're not using Swift and don't want to use dynamic frameworks
  use_frameworks!

  # Pods for testing_gowtham
 pod 'Firebase/Core'
 pod 'Firebase/Firestore'

end
2

Wenn der obige Fehler bei der Installation von pod 'PusherSwift' Und pod 'AlamofireImage' Auftritt, müssen Sie das Symbol # Von entfernen

   # platform :ios, '9.0'.

Dann schreiben Sie den Befehl pod install in Ihr Terminal.

Wenn Sie das Projekt erneut ausführen, wird der Fehler gemäß 'pusher Swift' Angezeigt. Klicken Sie auf die Option zum Entsperren. Das Problem wurde erfolgreich gelöst.

0
kurupareshan