web-dev-qa-db-ger.com

Fehlerbehebung beim Lesen der Dateiattribute für "/Users/path/myapp/Images.xcassets" in Xcode?

Plötzlich bekomme ich einen Fehler in Xcode 9 Beta

"Fehler beim Lesen der Dateiattribute für" /Users/path/myapp/Images.xcassets "in Xcode?" und nicht in der Lage zu bauen, ich habe einfach den Ordner "Images.Xcassets" nach oben gezogen, das war's. 

Ich habe Ziele überprüft, Copy Bundle Resources und "Images.Xcassets" Ordner vorhanden. Aber ich kann das Projekt nicht bauen.

Ich habe herausgefunden, dass mein Ordnername images.Xcassets lautet. Der Gruppenname und der vollständige Pfad sind Images.xcassets. Sie sollten den Gruppennamen und den vollständigen Pfad im Dateiinspektor überprüfen.

 enter image description here

BEARBEITEN:
Hier sind zwei Lösungen:
1. Entfernen Sie die Gruppe aus dem Project Navigator (ALT + 1), und fügen Sie die Dateien erneut hinzu (OPTION + ALT + A).
2. Klicken Sie im Datei-Inspector auf das Ordnersymbol (OPTION + ALT + 1) und wählen Sie einen neuen Ordner aus. 

27
Erick Yim

Es ist eine Ausgabe des neuesten Xcode9. Es gibt zwei Möglichkeiten, dieses Problem zu lösen. 

Folge diesen: 

  1. Entfernen Sie den Verweis auf die images.Xcassets-Datei aus Ihrem Projekt. Wenn Sie es aus dem Projekt entfernen und erneut zum Projekt hinzufügen, wurde mein Problem gelöst. 

 enter image description here

  1. Wenn Option 1 nicht funktioniert, löschen Sie die gesamte images.Xcassets-Datei (Papierkorb) und fügen Sie das Symbol erneut hinzu. 

Stellen Sie sicher, dass Sie dies in Ihrem Symbolnamen Build-Einstellungen hinzufügen.

12
Jamshed Alam

Msgstr "Xcode beenden und neu starten." es hat für mich geklappt. Ich habe das gleiche Problem mit Xcode-9.0. Ich habe es auf verschiedene Weise ausprobiert, beispielsweise abgeleitete Daten löschen, das Projekt bereinigen und den Xcode schließen, aber es hat nichts funktioniert. 

Löschen Sie die abgeleiteten Daten und beenden Sie den X-Code Cmd + q Beenden Sie den X-Code und öffnen Sie ihn erneut.

8
Smart guy

Ich hatte das gleiche Problem, mit lokalen Schoten. Offenbar unterscheidet xcodebuild jetzt zwischen Groß- und Kleinschreibung in Bezug auf den Ressourcenpfad. ~/Ordner/MyProject! = ~/Ordner/MyProject

2
Leonir Alves

Durch Schließen und erneutes Öffnen von Xcode wurde das Problem für mich behoben

0
Fran