web-dev-qa-db-ger.com

java.lang.NoSuchMethodError: com.google.common.base.Preconditions.checkArgument

Ich versuche, dieses Grpc-Java Beispiel auf meinem lokalen auszuführen. Entsprechende Proto-Datei dafür ist hier . Wenn ich versuche, auf lokalem hereinzulaufen, wirft es die folgende Ausnahme von hier aus:

Exception in thread "main" Java.lang.NoSuchMethodError: com.google.common.base.Preconditions.checkArgument(ZLjava/lang/String;Ljava/lang/Object;Ljava/lang/Object;)V
    at io.grpc.ServiceDescriptor.validateMethodNames(ServiceDescriptor.Java:129)
    at io.grpc.ServiceDescriptor.<init>(ServiceDescriptor.Java:83)
    at io.grpc.ServiceDescriptor.<init>(ServiceDescriptor.Java:51)
    at io.grpc.ServiceDescriptor$Builder.build(ServiceDescriptor.Java:219)
    at io.grpc.examples.helloworld.GreeterGrpc.getServiceDescriptor(GreeterGrpc.Java:251)
    at io.grpc.examples.helloworld.GreeterGrpc$GreeterImplBase.bindService(GreeterGrpc.Java:84)
    at io.grpc.internal.AbstractServerImplBuilder.addService(AbstractServerImplBuilder.Java:125)
    at io.grpc.internal.AbstractServerImplBuilder.addService(AbstractServerImplBuilder.Java:63)
    at com.cw.predictive.HelloWorldServer.start(HelloWorldServer.Java:56)
    at com.cw.predictive.HelloWorldServer.main(HelloWorldServer.Java:92)

Dies ist meine pom.xml wie erwähnt hier :

 <dependencies>
         <dependency>
          <groupId>io.grpc</groupId>
          <artifactId>grpc-netty</artifactId>
          <version>1.1.2</version>
        </dependency>

      <dependency>
        <groupId>io.grpc</groupId>
        <artifactId>grpc-protobuf</artifactId>
        <version>1.1.2</version>
      </dependency>

      <dependency>
        <groupId>io.grpc</groupId>
        <artifactId>grpc-stub</artifactId>
        <version>1.1.2</version>
      </dependency>
  </dependencies>
21
Naresh
**Please add following dependencies in your project.**
<dependency>
    <groupId>com.google.guava</groupId>
    <artifactId>guava</artifactId>
    <version>23.6-jre</version>
</dependency> 
<dependency>
    <groupId>org.Apache.httpcomponents</groupId>
    <artifactId>httpcore</artifactId>
    <version>4.4.8</version>
</dependency>
15
Avinash Pande