web-dev-qa-db-ger.com

WordPress 5-Upgrade: Bis wann ist es sicher, das Projekt in 4.x weiter auszuführen?

Wie angekündigt, wird Wordpress Version 5 diesen Dezember auf den Markt kommen. In Anbetracht der Verfügbarkeit von Sicherheitsunterstützung und Patches für frühere Versionen (4.9.x, 4.8.x, 4.7.x), bis wann kann das Upgrade auf 5.x verschoben und Projekte in 4.x ausgeführt werden?

1
Marcos Buarque

Wie gesagt hier :

Die einzige aktuell offiziell unterstützte Version ist WordPress 4.9.8. Vorherige Hauptversionen können Sicherheitsupdates erhalten, wenn schwerwiegende Exploits entdeckt werden.

Und das war schon immer so - nur eine Version wird offiziell unterstützt.

Daher ist es immer eine schlechte Idee, Aktualisierungen zu verschieben.

Wenn Sie also Angst vor Gutenberg haben, sollten Sie:

  1. Bereiten Sie eine Testversion für Ihre Site vor und prüfen Sie, ob es Probleme mit 5.0 gibt.

  2. Deaktivieren Sie Gutenberg, wenn Sie es nicht verwenden möchten.

Sie können Gutenberg mit diesem Code deaktivieren:

if (version_compare($GLOBALS['wp_version'], '5.0-beta', '>')) {
    // WP > 5 beta
    add_filter('use_block_editor_for_post_type', '__return_false', 100);
} else {
    // WP < 5 beta
    add_filter('gutenberg_can_edit_post_type', '__return_false');
}

oder mit einem der verfügbaren Plugins.

3