web-dev-qa-db-ger.com

Warum wurde keine Tkinter-Distribution gefunden?

Ich habe ein Problem bei der Installation von tkinter. Ich habe Version 2.7.11. Ich habe den pip install tkinter bei dos eingegeben, aber es wird folgende Meldung angezeigt:

tkinter sammeln 

Konnte keine Version finden, die die Anforderung tkinter (von Versionen:) .__ erfüllt. Keine passende Verteilung für tkinter gefunden

Ich habe die Flasche mit dem gleichen Verfahren erfolgreich installiert, aber für tkinter zeigt es ein Problem. Wie kann ich dieses Problem lösen? 

25
Syed Hissaan

Sie sollten installieren

apt-get install python-tk

Dies sollte Ihr Problem lösen

Die Tkinter-Bibliothek wird bei jeder Python-Installation standardmäßig verwendet

Versuche dies:

import Tkinter as tk
10
Prabhakar

die folgende Antwort für Windows:

nachdem Sie Tk auf Ihrem Windows-Computer installiert haben, folgen Sie den Anweisungen unter dem folgenden Link ( https://tkdocs.com/tutorial/install.html#installwin ), importieren Sie tkinter als tk (für python3) oder importiere Tkinter als tk (für python2). Zu Ihrer Information - 'Tkinter' wurde in python3 in 'tkinter' umbenannt. Es hat gut funktioniert für mich.

1
Geetha

pip shown Es konnte keine Version gefunden werden, die der Anforderung entspricht python--tkinter (from versions:) Keine passende Verteilung gefunden für python--tkinter Du benutzt pip version 10.0.1, jedoch version 19.0.3 ist verfügbar. Sie sollten ein Upgrade über das python -m pip install --upgrade pip Befehl.

1
ongja teenage

so finden Sie Ihren Paketlauf:

Sudo yum search python | grep tk

meins war:

yum installiere python3-tkinter.x86_64

1
costamatrix

Folgen Sie dieser Anleitung, um "tkinter" zu installieren. Ab Python Version 3.1 ist es jedoch Teil der Standard-Python-Distribution.

Sie können es auch mit Sudo apt-get install python3-tk-dbg installieren, wenn Sie sich in virtualenv befinden. (Dasselbe kann für die normale Installation gemacht werden, nicht nur für die Virtualisierung.)

0
Khushhalm

Ich musste python3-tk manuell installieren, bevor es funktionierte (via apt-get)

0
Bobbyy Tables